Problem after updating firmware. blue 8.32b
#1
Hi All, For the last couple of days, after finally getting a GPS antenna, I have been able to start testing 1935.
Everything appeared to be fairly normal with the "E" antenna although I had a lot of noise and interference on the ferrite antennas.

Early this morning I updated the firmware from blue 8.2 to the latest firmware listed, blue 8.32b.
The upload appeared to be successful.
However, although the station stats appear to have my station as running, I appear to be offline and it does not appear to be sending any signals?
The debug log is repeating the following sequence over and over again.


2017-09-05 11:17:45    109 | GPS: 1PPS deviation too high 307330. Reset counter!
2017-09-05 11:17:45    109 | AMP2: Set gain 6 on channel 0, op-amp 0
2017-09-05 11:17:45    109 | AMP2: Set gain 5 on channel 0, op-amp 1
2017-09-05 11:17:46    110 | GPS: 1PPS deviation too high 267908. Reset counter!
2017-09-05 11:17:46    110 | GPS: Bad accuracy, resetting smoothing.
2017-09-05 11:17:47    111 | GPS: 1PPS deviation too high 249264. Reset counter!
2017-09-05 11:17:47    111 | GPS: 1PPS inaccurate! Counter is 44268950, should be around 84000000
2017-09-05 11:17:49    113 | EVENT: GPS 1PPS counter is accurate again.
2017-09-05 11:17:49    113 | GPS: 1PPS OK
2017-09-05 11:17:50    114 | GPS: 1PPS deviation too high 40448537. Reset counter!
2017-09-05 11:17:50    114 | GPS: 1PPS inaccurate! Counter is 43500712, should be around 84000000
2017-09-05 11:17:50    114 | REMOTE-CONFIG: Server '2' deactivated
2017-09-05 11:17:50    114 | REMOTE-CONFIG: Server '2', expert '0'
2017-09-05 11:17:50    114 | REMOTE-CONFIG: Server '2' activated
2017-09-05 11:17:50    114 | REMOTE-CONFIG: Server '2', expert '1'
2017-09-05 11:17:50    114 | REMOTE-CONFIG: Done with 5 updates and 0 errors
2017-09-05 11:17:52    116 | GPS: 1PPS OK
2017-09-05 11:17:55    119 | AMP2: Set gain 5 on channel 0, op-amp 0
2017-09-05 11:17:55    119 | AMP2: Set gain 3 on channel 0, op-amp 1
2017-09-05 11:18:00    122 | RTC: Setting RTC from GPS time, time difference was -2s
2017-09-05 11:18:06    128 | ADC: Watchdog is pending since 2s (0x25 0x24 0x24) -> RESET -> (0x24 0x24 0x24)
2017-09-05 11:18:06    128 | REMOTE-CONFIG: Server '2' deactivated
2017-09-05 11:18:06    128 | REMOTE-CONFIG: Server '2', expert '0'
2017-09-05 11:18:06    128 | REMOTE-CONFIG: Server '2' activated
2017-09-05 11:18:06    128 | REMOTE-CONFIG: Server '2', expert '1'
2017-09-05 11:18:06    128 | REMOTE-CONFIG: Done with 5 updates and 0 errors
2017-09-05 11:18:07    129 | ADC: Watchdog is pending since 3s (0x29 0x28 0x28) -> RESET -> (0x28 0x28 0x28)
2017-09-05 11:18:07    129 | AMP2: Set gain 5 on channel 0, op-amp 1
2017-09-05 11:18:08    130 | ADC: Watchdog is pending since 4s (0x25 0x24 0x24) -> RESET -> (0x24 0x24 0x24)
2017-09-05 11:18:12    134 | REMOTE-CONFIG: Server '2' deactivated
2017-09-05 11:18:12    134 | REMOTE-CONFIG: Server '2', expert '0'
2017-09-05 11:18:12    134 | REMOTE-CONFIG: Server '2' activated
2017-09-05 11:18:12    134 | REMOTE-CONFIG: Server '2', expert '1'
2017-09-05 11:18:12    134 | REMOTE-CONFIG: Done with 5 updates and 0 errors
2017-09-05 11:18:18    140 | AMP2: Set gain 6 on channel 0, op-amp 0
2017-09-05 11:18:18    140 | AMP2: Set gain 2 on channel 0, op-amp 1
2017-09-05 11:18:28    150 | AMP2: Set gain 5 on channel 0, op-amp 1
2017-09-05 11:18:39    161 | REMOTE-CONFIG: Server '2' deactivated
2017-09-05 11:18:39    161 | REMOTE-CONFIG: Server '2', expert '0'
2017-09-05 11:18:39    161 | REMOTE-CONFIG: Server '2' activated
2017-09-05 11:18:39    161 | REMOTE-CONFIG: Server '2', expert '1'
2017-09-05 11:18:39    161 | REMOTE-CONFIG: Done with 5 updates and 0 errors
2017-09-05 11:18:40    162 | AMP2: Set gain 5 on channel 0, op-amp 0
2017-09-05 11:18:40    162 | AMP2: Set gain 4 on channel 0, op-amp 1
2017-09-05 11:18:45    167 | REMOTE-CONFIG: Server '2' deactivated
2017-09-05 11:18:45    167 | REMOTE-CONFIG: Server '2', expert '0'
2017-09-05 11:18:45    167 | REMOTE-CONFIG: Server '2' activated
2017-09-05 11:18:45    167 | REMOTE-CONFIG: Server '2', expert '1'
2017-09-05 11:18:45    167 | REMOTE-CONFIG: Done with 5 updates and 0 errors
2017-09-05 11:18:50    172 | GPS: Receive OK
2017-09-05 11:18:50    172 | EVENT: GPS data check ok.
2017-09-05 11:18:50    172 | GPS: Everything OK
2017-09-05 11:18:51    173 | REMOTE-CONFIG: Server '2' deactivated
2017-09-05 11:18:51    173 | REMOTE-CONFIG: Server '2', expert '0'
2017-09-05 11:18:51    173 | REMOTE-CONFIG: Server '2' activated
2017-09-05 11:18:51    173 | REMOTE-CONFIG: Server '2', expert '1'
2017-09-05 11:18:51    173 | REMOTE-CONFIG: Done with 5 updates and 0 errors
2017-09-05 11:18:51    173 | AMP2: Set gain 3 on channel 0, op-amp 1
2017-09-05 11:18:57    179 | REMOTE-CONFIG: Server '2' deactivated
2017-09-05 11:18:57    179 | REMOTE-CONFIG: Server '2', expert '0'
2017-09-05 11:18:57    179 | REMOTE-CONFIG: Server '2' activated
2017-09-05 11:18:57    179 | REMOTE-CONFIG: Server '2', expert '1'
2017-09-05 11:18:57    179 | REMOTE-CONFIG: Done with 5 updates and 0 errors
2017-09-05 11:19:04    185 | REMOTE-CONFIG: Server '2' deactivated
2017-09-05 11:19:04    185 | REMOTE-CONFIG: Server '2', expert '0'
2017-09-05 11:19:04    185 | REMOTE-CONFIG: Server '2' activated
2017-09-05 11:19:04    185 | REMOTE-CONFIG: Server '2', expert '1'
2017-09-05 11:19:04    185 | REMOTE-CONFIG: Done with 5 updates and 0 errors
2017-09-05 11:19:06    187 | AMP2: Set gain 6 on channel 0, op-amp 0
2017-09-05 11:19:06    187 | AMP2: Set gain 5 on channel 0, op-amp 1
2017-09-05 11:19:14    195 | REMOTE-CONFIG: Server '2' deactivated
2017-09-05 11:19:14    195 | REMOTE-CONFIG: Server '2', expert '0'
2017-09-05 11:19:14    195 | REMOTE-CONFIG: Server '2' activated
2017-09-05 11:19:14    195 | REMOTE-CONFIG: Server '2', expert '1'
2017-09-05 11:19:14    195 | REMOTE-CONFIG: Done with 5 updates and 0 errors
2017-09-05 11:19:16    197 | AMP2: Set gain 5 on channel 0, op-amp 0
2017-09-05 11:19:16    197 | AMP2: Set gain 3 on channel 0, op-amp 1
2017-09-05 11:19:26    207 | AMP2: Set gain 6 on channel 0, op-amp 0
2017-09-05 11:19:26    207 | AMP2: Set gain 5 on channel 0, op-amp 1
2017-09-05 11:19:34    215 | ADC: Watchdog is pending since 2s (0x25 0x24 0x24) -> RESET -> (0x24 0x24 0x24)
2017-09-05 11:19:34    215 | REMOTE-CONFIG: Server '2' deactivated


This morning I tried updating again, and the result is the same.
I have read through most of the forums, looking for anything similar or related, but I have not been able to find anything.
I have of course tried switching it on and off and rebooting, all the LED sequences and beeps and the temperature of the chips seem to be O.K.
The signals, see:-

https://www.dropbox.com/s/ptqxgiuhulrxpmr/Screenshot%20from%202017-09-05%2013%3A42%3A18.png?dl=0

Again this seems to keep repeating this strange waveform and the numbers are just leaping about randomly.
I am now at a dead end, I don't know what else to do! 
Thanking you all in advance for any help.
Kindest regards,

Brian. Huh


Attached Files Thumbnail(s)
       
Reply
#2
After doing some tests with a multimeter. It appears C430 is now a short circuit and L403 is now open circuit, R405, the closest path to ground still reads 82 ohms?
My test equipment, little experience with failures in SMD parts and lack of replacements for these components doesn't permit me to come to any further conclusions at present.
Something has caused C430 to fail and it appears that L403 has acted as a fuse?
I will try to get replacements as quickly as possible and hope that not too much else is damaged.
Obviously, without L403 there is no power to the amplifier for the E antenna. Therefore no signals!
Any suggestions gratefully accepted.

Brian.
Reply
#3
Even after replacing the broken parts it still does not function corrrectly.
I am extremely disappointed that after only two days of very limited use I am now left with a useless, but very expensive ornament.
My technical skills are not sufficient to even start trying to analyse the circuit boards and the chips.
Judging from the position of the faulty components and the fact that the smpsu has also developed a fault, it now only works at about 4.3 volts off-load and much less than that if there is anything in its output? My guess would have to be some sort of mains voltage transient?
Is there anyone out there willing to help, or do I just put my name down again for another chance at getting a new unit in time for next years "season?"
Has anyone else had a problem like this?

Brian.
Reply
#4
(2017-09-05, 18:02)readbueno Wrote: Even after replacing the broken parts it still does not function corrrectly.
I am extremely disappointed that after only two days of very limited use I am now left with a useless, but very expensive ornament.
My technical skills are not sufficient to even start trying to analyse the circuit boards and the chips.
Judging from the position of the faulty components and the fact that the smpsu has also developed a fault, it now only works at about 4.3 volts off-load and much less than that if there is anything in its output? My guess would have to be some sort of mains voltage transient?
Is there anyone out there willing to help, or do I just put my name down again for another chance at getting a new unit in time for next years "season?"
Has anyone else had a problem like this?

Brian.

Hello Brian,

I'm very sorry to hear about your difficulties. From reading this forum, and perhaps
http://www.wxforum.net/index.php?board=115.0 you may not have to "get back to the end of the line". I thought that I read that in some cases, you may be able to get a replacement sooner than you think. Perhaps an email to Egon would be in order.

I don't know how static sensitive the boards are. But even though the humidity here (SW MO) has been above 50%, I did most of the work on the anti-static mat here. I guess it's a moot point now, but is the air very dry where you live? The lower the humidity, the more important it is to use grounded antistatic mats and/or wrist straps when handling static-sensititive devices. Sometimes just a few volts can destroy an IC.
Regards,
Mike
http://www.w0btu.com
Stations: 1977
Reply
#5
Hi mwaters, Thank you very much for your concern and your PM, I am unable to reply because I don't seem to have permission?
I have accepted your request in my CP.
Your link also just gets me to the "WXforum.net » Weather Station Hardware » Blitzortung" and not to any particular post.
I have been in touch with Egon about something else and I have mentioned my problem in a email I sent to him this evening.
Funny you should mention humidity, as far as I can tell the system failed just after our first rainfall in nearly six weeks.
Normally I have found that chips in circuit are not nearly as sensitive as chips on the loose, the most dangerous time appears to be from when you remove it from the safety of the bag and the foam, if it has any, until the time that you get it safely soldered into its new situation.
Living in the boonies, as I do, our mains voltages can be a bit haphazard, although it has improved from the times when you could tell when your neighbour was making coffee or had switched the oven on by the strange patterns on the TV. ;-) We now have Digital TV, so maybe we still don't have that much improvement with the voltages? :-)
The advantages are of course, that we don't get the same types of interference that you can get in a city.
In my short operating time I was getting quite good efficiency on my signals and it was a post in one of the forums that inspired me to upgrade the firmware, at that time, to see if there was any improvement!
I am still hopeful that my board can be returned to full working condition. Unfortunately, I am limited these days in my use of good test facilities and the tools to trace the fault.
I have a multi-meter and that will do the basic stuff, but I am not really of an age to understand the ins and outs of micro-controllers and the shaky hands and failing eyesight makes working on surface mount stuff a bit tricky. I am working my way systematically though the schematics and just using basic ohms law stuff to get the broken bits fixed.
However, software and broken bits with little more than three legs may prove to be too much.
It is late here and I must go.
Catch you again soon,

Brian.
Reply
#6
(2017-09-05, 14:33)readbueno Wrote: After doing some tests with a multimeter. It appears C430 is now a short circuit and L403 is now open circuit, R405, the closest path to ground still reads 82 ohms?
My test equipment, little experience with failures in SMD parts and lack of replacements for these components doesn't permit me to come to any further conclusions at present.
Something has caused C430 to fail and it appears that L403 has acted as a fuse?
I will try to get replacements as quickly as possible and hope that not too much else is damaged.
Obviously, without L403 there is no power to the amplifier for the E antenna. Therefore no signals!
Any suggestions gratefully accepted.

Brian.

Brian,

I was just studying the schematic. Here are a couple of thoughts.

If the coax between the two boards was shorted, that would blow L403.
Same thing if the E-field board was shorted.
As for C430, perhaps a HV spike from the E-field board?
Regards,
Mike
http://www.w0btu.com
Stations: 1977
Reply
#7
Have you disabling the E-Field channel and see if you can get anything on the H-Field?
Kevin McCormick KB0UOI
Macomb, IL USA
Stations: 1539
Reply
#8
(2017-09-06, 23:08)kevinmcc Wrote: Have you disabling the E-Field channel and see if you can get anything on the H-Field?

This is a GREAT idea!

IIRC, you only have one H-field antenna. If that's the case maybe add a second H-field antenna.
Regards,
Mike
http://www.w0btu.com
Stations: 1977
Reply
#9
Hi again, There is not a short on the coax.
The E-field board has a BAT54s (two zener diodes) on the antenna side and they are both intact and they are in parallel with the red led that goes to ground via  a 2.2k resistor on the output side to the main board the red led still lights up. The 3.3mh inductor on that board is also O.K. therefore I think pcb_17.1 has survived.
I have tried using the different channels one by one with the rest disabled, the results while different are not what one would expect on any of them.
Both pre-amps do appear to function. I still think it is pcb 19.c? 
I will have another look at the main board tomorrow, there are four identical channels for the most part, maybe I will get lucky and find something easy to replace! ;-)
O.K. After a very late night, I had another look this morning and I am loath to start swapplng things about, after my tests on the individual channels I think the problem
is with the logic or micro-controller, both of which are beyond my pay-grade.
I have written some ideas below.

Brian. Sad
Reply
#10
(2017-09-06, 21:27)readbueno Wrote: Hi mwaters, Thank you very much for your concern and your PM, I am unable to reply because I don't seem to have permission?
 [snip]

You're welcome. Let me check my forum settings and see if I can fix that.
Regards,
Mike
http://www.w0btu.com
Stations: 1977
Reply
#11
Hi All, What are the differences between pcb 19.3b and 19.3c?

Brian.
Reply
#12
                 

O.K. I have switched back to version 8.2 but the status on the map page still says 8.3b. so there still seems to be a fault with the communication.

I was only running for a short while, but, as you can see, very little has changed.
It does seem that the E channel is not going negative and the other two are just generating garbage interference.


I will have a another go at it tomorrow. Huh

Brian.
Reply
#13
The Devs only know the difference between 19.3 B and C.

Unfortunately they have not updated the compendium.
Kevin McCormick KB0UOI
Macomb, IL USA
Stations: 1539
Reply
#14
(2017-09-07, 03:43)kevinmcc Wrote: The Devs only know the difference between 19.3 B and C.

Unfortunately they have not updated the compendium.

I think the only differences are in positioning of the GPS module, SMA and the Network Connector... minimizes some possible cross noise, and the removal of the E field supply voltage jumper, that voltage is now fixed at 4.5v... the alt voltage no longer needed. Additionally, a 5 volt pin now available on the SWD connector. That last mostly so Egon has less steps to do when he initializes a board before distribution to an operator.

Also, in general, as far as operational and installation principles and such, if it applies to system RED it can be applied to BLUE...  if you're running 'Bare Blue" with no filters, only 2 H fields, you'll see virtually no operational differences... main difference is RED E Feld has up 2 three 'bandwidth' using 3 channels) whereas BLUE only uses 1, with the provision for the optional filter IC. Now, the differences are bandwidth, power distribution, circuit design and technology, options, etc... but for example, noise and interference, sensitivity, etc are very similar... you don't need specialized BLUE knowledge to 'troubleshoot' signal, noise, etc issues from an operational environment.... from a 'technical' and structural point of view, there are drastic differences, but for general operation, if it applies to RED,  it's good for Blue...

One thing to check on the dead system with the blown coil... check the RJ 45 jack for corrosion, especially if the H preamp was outside, and you had the rain....
                   TwinHollies WeatherCenter  Frankfort KY, USA
  Americas Operators at Sferics.us
        Stations: 689, 1439
Reply
#15
Hi All, After my experience of the last couple of days, I now think that the board is not repairable.
Whilst I have not been able to ascertain exactly what the actual event was I do believe that it might have been preventable!
Whilst accidents do happen in a properly designed product the affects of these are mitigated or held to at least minimum and repairable damage.
I don't think this is the case with PCB 19.c?

Some ideas about  Circuit Protection.

Like this Maybe?

   

Input protection can be classified into two broad categories. Ones which
protect against software or configuration bugs, or misuse; while the other
protects against exposure to the outside world. We will discuss protection
from software configuration bugs and misuse first.

The three main areas we are interested in are:-

1. Over voltage protection.

2. Over current protection.

3. Over temperature protection.

The first thing anyone who has been around the block a few times will tell you,
is that it is always a good idea to throw a series resistor (Rs) in the path of
any MCU input or not connected leads. This limits the current from the outside world into (or out of)
your MCU. Why does this matter?

A floating input (or output) will produce random and strange results which
might not be easy to debug.
Consider if someone(or you) decides to modify the software which configures
the pin to something other than what was intended? Or if this is allowed to
happen by accident.

Smoke happens.

If that isn't bad enough, consider someone realizes that "pushing" the button
or an instruction would be a bad thing and may cause a short. But they
rationalize to themselves that the push button (for whatever reason) isn't
going to be pressed.
However, what if the pin which is configured as an input, is set (or by
accident is set) to a logical 0. Boom! Out go the lights.

The Software has just created a direct path from Vcc to ground.!
Designs with additional input protections are more difficult to design,
layout and produce, but they can protect you from just about anything.

This is not a cheap kit and these protections are necessary! 
Just add them on any future boards and don't rely on LUCK.
It's only a few cents and some space on the PCB. (There is space!)
Usually I don't mind spending a little more of either one for a more
robust design. In this case it should not even be an issue!

Are we using the right input protection?

An important aspect of designs for this environment is interfacing sensitive 
electronics with inputs coming from the harsh conditions of real life.
When interfacing digital circuitry with the outside world, care must be taken
to protect the sensitive electronics. However, the circuitry required to
provide the protection is small, inexpensive, and easy to understand.
If a little bit of forethought is used when designing the system, many
difficulties can be avoided once the system is deployed. 
Usually, inputs are read by some sort of intelligent processor such as a
microcontroller.
In cases like these, it is imperative to protect the processor from all the
inputs, while still providing a usable signal for the processor to read. 
In a typical system there may be several different sensors and a control panel
with the central processing unit. These sensors are connected to central
processing via relatively long wires. Unfortunately this can lead to
inadvertent electronic failure. Long wires can act as an inductor and when a
switch is opened or closed, large voltage spikes can show up on these
electronic paths.
It is not unknown for large voltage spikes to also turn up on power supply
voltages either.
Typical microcontrollers have input impedance on the order of 20 MΩ.
In addition to the normal system voltages ranging from a few milliVolts to
about 5.0 V. it is easy to see the problems with unprotected inputs.
Any large voltage that shows up on any input is presented directly to the
interior electronics (microcontroller). Regardless of how this voltage is
produced (ESD, induced EMI, switch closure, user error), this can damage the
microcontroller, and perhaps cause the entire system to fail.
Because of this, different protection strategies must be implemented to create
a more robust system. 
An important aspect of microcontroller inputs (and the vast majority of any
logic ICs) is that they have internal protection diodes that are used to
protect the inputs, these normally forward bias at 0.7 V.
Under ideal circumstances, this can protect the microcontroller.
However, if the voltage is large enough or lasts for a long enough time, it
can destroy the internal diodes in a shorted position, thereby ‘breaking’ the
input pin. Even worse, the input pin is now directly connected to a power rail,
so, when the next large voltage shows up on the input pin, it is shunted
directly to the power bus, wreaking havoc throughout the microcontroller and
most-likely damaging it further.
Even if the diodes are not destroyed, a large ESD spike can induce a current
surge through the microcontroller’s power bus, which can corrupt internal
registers and settings leading to unpredictable behavior.
With all of this in mind, the first attempt to protect these inputs is found
with current limiting

Current limiting 

The simplest protection mechanism is a current limiting resistor, the input
resistor is sized so that the voltage drop across it does not affect the
voltage at the microcontroller input. As this is a simple voltage divider, and
the input resistance in the controller is about 20 MΩ, this resistor can be
fairly big. For most digital inputs, a good value is between 100 Ω and 10 kΩ.
For our system, a value of 1 kΩ is used.
This type of protection may work well for short wire connection lengths and
enclosed wire runs (where there is little chance of EMI, etc.).
However, the overshoot or the ringing from the pulse may still exceed the
ratings for a particular system. With the addition of a capacitor, more protection can be added by
turning the simple current limit circuit into a simple low-pass filter.

This type of circuit, can rapidly suppress most spikes, but a little more
thought must be applied to component selection, Because of the frequency
limiting characteristics of the circuit, the value of the resistor and the
capacitor must be sized so that the microcontroller does not miss any signals.
The Equation for determining the resistor and capacitor values in a low pass
filter circuit, of this type, used for a digital input is. (More or less!)

Rise time =2.2RC where the waveform rise time is for the fastest required
incoming leading edge.

To calculate the value of R and C, use the following steps:

Find the fastest edge of the incoming signal – or determine the fastest
frequency of the incoming signal and assume an edge speed of 1/100th of the
input period (a 1 kHz input frequency has an edge of 10 µs).

Select ‘R’. Usually this can be selected to a common value already in the
system, such as 1 kΩ.
 Use the equation above to determine the value of ‘C’.
In some cases, the input signal is a very slow moving signal (button press,
switch closure, etc.), so the value of ‘C’ can be then changed to also match a
common value on the board, as long as the order of magnitude is maintained.

One added advantage to the RC filter circuit for a digital inputs is that it
also rejects spurious/fast inputs that could cause false readings on the
microcontroller. Unfortunately, for large ESD events and long wire runs, there
can still be voltage spikes in the microcontroller because the circuit is
relying on the clipping action of the internal diodes. This leads to the next
approach.

External clipping diodes 

To assist the use of the microcontroller’s internal diodes, external Schottky
clipping diodes can be used. Schottky diodes are implemented because they
conduct before the internal diodes of the microcontroller (Schottky diodes
forward bias at about 0.2 V as opposed to the 0.7 V of the internal diodes).
Note that a small series resistor is used to protect the Schottky diodes from
overcurrent. As these diodes are only on for a very short time, a small
resistor works well; something on the order of 10 Ω usually works fine.
Alternatively, the 10 Ω resistor can be omitted if the Schottky diodes are
beefy enough to handle short-duration, high current pulses.

So for the most ruggedized digital input protection, a combination of external
resistors, capacitors, and fast diodes should be used.
This should be considered the minimum protection required in any product.

The type of signals that we are trying to capture may make this something off a
design comprimise, but it could be better than it is.

Other ideas 

These basic ideas can be further expanded for known higher voltage inputs.
Intentionally or accidently!
For example, if the input signal was changed to switching a high voltage
instead of to ground.
The input clipping diodes to ground are also to protect from less than zero
volt spikes. The damage is often caused by excessive peak to peak wave forms.
The input clipping diodes to just the positive bus is not sensitive enough, 
removing or adding the faster Schotky zener diodes after the current limiting
resistor gives better protection.
This also provides a known voltage for the input pin and reduces the amount of
current shunted to the power bus. In addition, all of the connections on the
input are now referenced to ground. Note, in this case, the current limiting
resistor must be sized small enough to provide enough current to allow zener
breakdown at the correct voltage (about 1 mA minimum).
i.e. These small zeners act like a fuse of a smaller rating than the internal
protection diodes of the chip, and being external to the chip are cheaper and
easier to replace in most events.

These techniques will help protect your MCU inputs from bugs in your software,
misuse and and other perils. These techniques should help protect them from
the harsh realities of the outside world which are not always under your
control.

Zener Diode Clamps

Selecting a fast Zener diode with a breakdown voltage slightly higher than the
expected input voltage will help prevent excessive voltage from reaching the
MCU. Again the Zener will prevent voltage exceeding the breakdown voltage by
beginning to conduct it away from the input. A series resistor (Rs) is
required. As an example, a single 5.6V Zener diode such as the 1N4734A can handle 1W
of power dissipation with peaks of 810mA. There are many others all of them
relatively cheap when we consider of factors.

PPTCs

A PPTC is a Polymeric Positive Temperature Coefficient device, used to protect
circuits from excessive current. That's a big long description, but it is more
commonly known as a self-resettable fuse. We all know how a regular filament
fuse works. Too much current and the filament breaks protecting the circuit
from excess current. Later someone replaces the fuse.
With PPTC devices, as the current through the device increases, the temperate
increases until it reaches its switching temperature resulting in a dramatic
non-linear increase in the resistance of the device into the mega-ohm region.
Once the power is removed the device will return to its normal operating state.
If the over-current conditions continues to exist, the process starts again.
PPTC devices exist which can exhibit this behavior milliseconds.
This technology is based on the thermal induced changes in the device material,
so they are also sensitive to changes in ambient temperature.
Typically In normal conditions it acts like a 220-ohm resistor, limiting
current to an input, if the set current is exceeded the device trips.
Devices with higher or lower normal condition resistance also exist.

MOVs

The MOV is a Metal-Oxide Varistor, used to protect circuits from excessive or
transient voltage spikes. Its a voltage dependent, nonlinear device that
provides very good transient voltage suppression. When exposed to high
transient voltage, the metal oxide varistor clamps voltage to a safe level.
A metal oxide varistor absorbs potentially destructive energy and dissipates
it as heat, thus protecting vulnerable circuit components and preventing
system damage.
The Littlefuse V8ZA2P is a 5.5 VDC device used to protect low voltage circuits.
It clamps voltages of up to 20V at a current of 5 amps with peak currents of
250A.
MOVs have been typically used on inputs from household AC line voltage into a
circuit to be protected as a surge protector, but can be used for low voltage
digital inputs as well. The MOV device is connect in between the input signal
and ground.
 
TVSs

The TVS is a Transient Suppression Diode, used to also protect circuits from
excessive or transient voltage spikes caused from ESD, inductive load switching
and other transient sources. Similar to MOVs you need to consider the maximum
amount of energy the device may need to absorb and the power handing
capabilities of the device while conducting. When a transient voltage occurs,
the TVS clamps instantly to limit the voltage to a safe level and conducts
current away from the circuit being protected. This is called the clamping
voltage (Vc). The operation is similar to a Zener diode, but TVS diodes are
faster acting and are designed to react more quickly to transients.
Zener diodes are designed for slow voltage changes and are more commonly used
in voltage regulators.

Over Temperature sensing devices.

There are many of these rangeing from a simple thermistor to Analog 
temperature sensors compatible with small microcontrollers whose output 
provides a voltage proportional to the ambient temperature, i.e. they are
temperature controlled voltage regulators.

Simple Common Sense Advice

Many of us are not electronics hobbyists and for many this may even be their
first construction of a kit. While the maounting of the through hole components
is not difficult a few basic pointers will prevent many quite common accidents.

1. Antistatic, ESD protection is essential while working on these boards.
This includes tools, soldering irons and even multimeters, some older types
can have quite high voltage present for measuring resistors and other
components.

2. Antistatic mats and wriststraps should be considered necessary. Some work
surfaces and even your body can generate very high charges.

3. Always switch off the device before making removing any connections, this
means the inter board connetions, the antennas,the router and the PSU.

4. Be particularly careful with probes for test instruments and when handling
the boards when they are working.

5. Never try to solder or change components on a live board, whilst the working
voltages are quite small, transient charges can destroy many sensitive
components.

While this certainly isn't an exhaustive, it should provide some
background and thought before your next design. Next time you have any
external device connected to some circuit input you may want to consider
one or more of these techniques. For further ideas you might look at something like this site:-

https://www.rugged-circuits.com/ruggeduino/

Kindest regards,

Brian.
Reply
#16
To Cutty, I agree with what you have posted, most of us are not technicians, however in this case "it was as needs must, when the devil drives."
The system is new, it is only in test for two days, it is inside and has not yet been exposed to the weather.
The only reason I mentioned the weather is that it is known that changes in weather conditions after long stable period are the time when most faults are reported/detected on mains distribution systems and transients are more likely at these times.
The destruction of two closely related components both physically and electrically would suggest some sort of transient over voltage?
I do believe that this is an excellent project and well worth supporting.
I will not give up.
I shall try again, and hopefully have better luck next time!

Brian. Huh
Reply
#17
(2017-09-05, 14:33)readbueno Wrote: Something has caused C430 to fail and it appears that L403 has acted as a fuse?
I will try to get replacements as quickly as possible and hope that not too much else is damaged.
Obviously, without L403 there is no power to the amplifier for the E antenna. Therefore no signals!
Any suggestions gratefully accepted.

Brian.

For me it looks like there have been a high voltage on coax input - ( You don't have an installation with 24v to antenna amplifiers?)


/Richo
Stations: 584, 585, 2017
Reply
#18
(2017-09-07, 15:32)RichoAnd Wrote:
(2017-09-05, 14:33)readbueno Wrote: Something has caused C430 to fail and it appears that L403 has acted as a fuse?
I will try to get replacements as quickly as possible and hope that not too much else is damaged.
Obviously, without L403 there is no power to the amplifier for the E antenna. Therefore no signals!
Any suggestions gratefully accepted.

Brian.

For me it looks like there have been a high voltage on coax input - ( You don't have an installation with 24v to antenna amplifiers?)


/Richo

Hi Richo, I think you may be on to something there, but not from the antenna, but from a voltage loop from the UPS that runs my computer & router and having the wallwart/phone smpsu charger plugged into a different socket with a separate earth connection.
It is possible under fault condition, for there to be a difference between the router virtual earth which also plugged in to the board and and the earth lead for the board.
Normally this would trip the Earth-leakage circuit breaker for the house?
I shall have a qualified electrician out to run some tests, maybe the circuit board was a faster fuse than the circuit breaker, which only limits the current between live and earth and not between two isolated circuits i.e. the UPS and the phone smpsu charger and a real external earth?
It is certainly another thing that can be checked.
Thank you.

Brian.
Reply
#19
(2017-09-07, 02:58)readbueno Wrote: I was only running for a short while, but, as you can see, very little has changed.
It does seem that the E channel is not going negative and the other two are just generating garbage interference.

Hi Brian,

The repetitive pattern on those 3 graphs almost looks like a bad switching power supply. Could the PS have damaged the controller, or vice versa? It's probably not, but I thought that I should mention it.

I power mine with the  5VDC 2A charger that came with my Android tablet.

73, Mike
http://www.w0btu.com
Regards,
Mike
http://www.w0btu.com
Stations: 1977
Reply
#20
Hi Mike, I was using a "high power" switched mode PSU, that now also refuses to produce its stated voltage and current.
What damaged what, is the Sixty-four million dollar question.
I have ordered the parts to make a dedicated Linear PSU that will have over voltage and over current protection built in and remote sensing, so the voltage that appears at the boards will be as correct as it should be.
This board is going back to Egon, for its post mortem, and I have bought a new board that I will be very careful with.
Regardless of my particular problem. I do feel that these boards should, for this price, be made as idiot-proof as possible?
Kindest regards,

Brian.
Stations: 1856
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  System Blue GPS problem Steve- 12 3,408 2016-11-15, 09:35
Last Post: DnH2016



Users browsing this thread: 1 Guest(s)