Firmware 10 on System Red PCB 10.5 - firmware bug ???
#1
Hello,

I installed the new firmware on my PCB 10.5 controller for System red. The PCB was manufactured according to schematic and Eagle-File:https://docs.lightningmaps.org/files/hardware/red/PCB_10_5.brd

The firmware did not work properly as the PCB-ID was not detectected correctly. It turned out that PCB 10.5 has a different coding then described.

Description according to the hardware reference in TablePCB Controller Ids:
 https://docs.lightningmaps.org/hardware/...system-red 

Id PCB System PD10 PD11 PD3 PD1 Offset
2 10.5   RED      -        +        -       -      0

but it turned out that actually Coding of PCB 10.4 and PCB 10.5 is different, PCB10.5 has the following coding:
Id PCB System PD10 PD11 PD3 PD1 Offset
? 10.5  RED      +        +        -       -       0

this can also be seen in the schematic of PCB 10.5,  so PD10 has a high level +5V  instead of GND like PCB 10.4.

I did cut off pin PD10 from the controller-board and now all is working; PCB 10.5 is detected as PCB10.4 now

... but it seems that there is a firmware bug in 10 RED ???? This potentially could affect several stations, as station list has decreased since new firmware is out
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Uploading Firmware! Please wait... Tecsol 2 14,904 2018-02-03, 17:17
Last Post: Mark.Smith
  Problem after updating firmware. blue 8.32b readbueno 30 135,949 2017-09-11, 23:51
Last Post: readbueno
  Updated firmware to 8.0 (RED) and station stopped working properly Geewizard 2 16,013 2016-08-28, 13:33
Last Post: Geewizard
  Why firmware is not open-source? EugeneF 2 19,401 2014-08-10, 23:24
Last Post: Tobi

Forum Jump:


Users browsing this thread: 1 Guest(s)